We bought a 2000 suzuki swift with 94,000 miles on it. The head lights dont turn on, but the parking lights work and the high beams work. Do you think its the fuse?


hi
im dave
Is there a leak in one of the fuel lines? Check the length of the fuel lines from the pump (you may need an extendable mirror to see the top of gas tank) right up to the point where it enters the fuel rail on the engine. Take special note of the junctions and try to do it with the car running and at a slight idle so fuel is pumping. Check next for a smell of too much gasoline along the fuel rail as one of the injectors may be improperly seated and or broken and leaking. Has the service engine check engine light come on at all or come on and gone out. If your o2 sensor(s) go you use more fuel. If they go there should be a code stored in your PCM (computer). You can pull any codes out of that car by finding the connector and jumping it. Also if your air element(filter) or any pipes are clogged in that system up to the throttle body you will use much more fuel.

Let me know how these tests go

Check bulbs. If high beams work, then the fuse is likely fine. Do double check fuse box anyway though.If all checks out, then check the headlight switch stalk with a multimeter.

If the other solutions did not work, may be problem in combination switch, located in steering column on lever for headlights.

You probably need a new combination switch, located in the steering column, integrated into the control lever for lights. Remove airbag (if you have one) and then pull off steering wheel to access switches. We bought ours at you-pull junkyard, but I believe AutoZone also carries them for far less than dealer price.

get new brushes for the alternator

Have you checked to see if this is a wiring problem or maybe a relay problem?

Recently my lights would work on side lights and not anything else and this was down to dodgy wiring and needed a new relay unit.


More: