Replaced control board, won't power up


I have model MDE5500AYW. I received the PF code on the LED display a few days ago. The dryer then failed to enter diagnostic mode, thus indicating I needed a new control board. I just received it and installed it. I now receive NO POWER to the board whatsoever (i.e., the control board will not light up). I was afraid something might have happened to the new board during shipment/whatever, so I reconnected the old board. SAME PROBLEM--no power.

Is there a re-set procedure or some such thing that I need to initiate after replacing the control board? I can't understand why there's suddenly no power coming to the board. There are only a few connections, and these are all solid (and I can do them from memory at this point!)

And yes, I plugged the dryer in after unplugging it to replace the board (and checked the circuit breakers . . . all is well). :)

Thanks!

You will need a volt meter to test the board for power.
First remove the cover at the cord terminal and verify 220 volts to the dryer as well as 120 volts from each hot leg to neutral.
If power is OK there,open the console to access the control board you replaced.The door must be closed. With the volt meter check for power at terminals BB1 position #1 and BB2 position #3.BB1 is L1 power in. BB2 is neutral power in. If no power is present check the door switch.
The L1 power comes from the terminal block to the door switch before it goes to the board.
If power is present at the board and nothing works you have a bad board.


More: