The write protect switch on my 2 Extreme Pro 64 GB cards keep sliding back to the locked position when I insert the cards in my camera. Is there a fix for this?


Good day,

This is a common problem that many people experience with their SD Cards.
It is normally an easy fix and you can follow a method that I posted on my tips here:

http://www.fixya.com/support/r7042428-sd_card_write_protect

Please feel free to let me know if this was helpful!

Regards

the 4800 is a older model that won't support a sdhc card-go back to 2gb or smaller and problem solved-don't waste money on high speed cards for a basic point and shoot camera

First of all, the 4GB card will never be able to work in your camera. Check on its face. It likely says SDHC, and SDHC cards as this format came out after your camera was designed (I know it looks exactly like a normal SD card, but it's not).

Now the 2GB card should work with your camera as it is a standard SD card. Remove the card from your camera. Look on the side of the card for the tiny slide switch, and slide it to the other "unlocked" position. Reinsert it in the camera, and see if that corrects the problem.

try puting the lock thing onto Lock. it worked for me

If you remove the card from the camera, there is a little switch on the SD Card. There is typically a label that shows which direction is locked. If not, switch it to the opposite side. This should solve the problem. Otherwise, there could be a problem with your card. I hope this solves the problem.


More: