Won't Power On


This camera has only been used approximately 3 times. It won't even power on. Tried new batteries but still doesn't work. Can't believe this camera failed in this short of time. The camera looks like brand new but I guess it is just a piece of junk.

Try buying very high quality recharable batteries. You might have low quality batteries and the camera eats the battery up quickly.

I had the same problem, same camera. So I checked to see if other digital cameras had the same problem, and some did. Seems to be with the batteries. I took out my memory card, and reinstalled the batteries that came with my camera, I've only had it a few days. Turned it on and it worked, so I took a pic, and then turned it back off and reinstalled the memory card, and made sure it was formatted. Turned the camera back on and it worked, and took another pic with no problems. The batteries I have right now are Panasonic Alkaline for Digital. They seem to be a heavier battery, because the cheaper ones are lighter and didn't work. So I say try that brand or make sure the batteries are for digital purposes. Hope this helps.

Either your camera board is dead, or you are not using the right batteries. There are 2 types of AA batteries on the market today. One type is the normal 1.5V batteries. The other is the special lithium batteries that run a slightly higher voltage, usually about 2V. Many camera owners do not know this fact.

This may or may not work (it's primarily a trick for certain Canon cameras with similar symptoms). Remove the cameras battery, then remove the memory card. Insert a BRAND NEW or fully charged rechargeable batteries. DO NOT insert the memory card. Instead, just turn on the camera. If the lens retracts, turn off the camera, insert the memory card, then restart the camera.

If this doesn't work, here are some other things to try. But don't get your hopes up, as they only seem to work for little less than half the cameras with similar problems:

http://camerarepair.blogspot.com/2007/12/fixing-lens-error-on-digital-camera.html

Check the memory card or battery door for the tab that activates the cut out switch. It ,or the switch, may have sustained damage. I'm not 100% on this model but if it's like the S5700/ S5800 models then the memory card door has a tab for the cut out switch to prevent card removal whist powered up.


More:

My car remote won't work... sometimes! (I think it's also referred to as a "fob"?) A lot of times I find myself repeatedly pressing the buttons (lock, unlock, set alarm, and open trunk) for my car, but it won't work. I'll try taking a couple steps back, walk around the car, point the remote at the car from high in the air... just some silly things to try and get it to work. I've also tried changing the battery and this just doesn't help. I have 2 of the same remote (2009 Chevy - with remote start) that I bought brand new online and had a car dealership program for me. One remote was for back-up in case the other one stopped working, like the one that came with the car. The first worked fine for a couple of months and now it's just frustrating to try and lock/unlock my car with them. I opened the second one and it works just as good as the first one... HORRIBLY! Like I said, I have tried changing the batteries, (ensuring it's the correct battery, of course) however it doesn't seem right for the battery to deplete in such a short time. Usually after a couple minutes of trying, the remote will magically work. However, after I got off work last night I spent about 10 minutes trying to get my remote to work and finally gave up (this was with second remote that I just opened about 4 days ago). My car alarm was going off and I couldn't stop it because my remote won't work! I've had enough of these games... please help me! I've only owned this car since July 2010. The remotes started acting up about 3 months after I got it. Do you have any ideas as to what the problem may be? Should I take my car in and get the receiver looked at?