E2 code Water in not coming Water out ok Cleaned out everything NEED new valve?


Hi most of the treadmill with e2 error code are related to the motor speed sensor so check the sensor

trying turning the water off. disconnecting the hose at the valve and hooking it up again.

Hello and welcome to fixya.

I'll start by saying you're right the "01" error code is indicating a fill problem has been detected by the control.

Have you tried just a "cold" water wash ? If not try selecting "quick wash" and on the dial turn it to #1 "cold" in the cotton setting see what happens. Do the same and select #3 "hot". If the error occurs in one and not the other, observe and either focus on the hot water valve or the cold main wash valve ( I don't think it is the cold prewash valve or the error would occur immediately ).

In fact I suspect it is the main wash cold valve ( dual valve ) since you haven't indicated the error occurs during prewash and the hot water valve is energized in prewash by design to help rinse out the detergent no matter what cycle or temp. you selected.

Having said all that, here's what you're dealing with. Even though you appear to have sufficient water flow as you stated you checked for, the electronic control doesn't think it is correct.
There are several factor's which could possibly be causing this error, a couple you've mentioned.

They are...

 Water supply turned off. ( obviously not in this case )

 Water inlet hose filters (strainers/screens) blocked. ( you've said you cleaned them out )

 Water pressure too low. ( must be no lower than 14.5psi and a max. of 145psi )

 Water inlet valve(s) has failed. ( this doesn't appear likely...at least at first, not completely failed based on your description...but the control may think it has. If you have an ohm meter you can check it. the coils should have a value of between 2.7 and 3.3k ohms. That means 2700ohms and 3300ohms. If not within those values the control will detect the value being incorrect , hence displaying the "01" error. Change the valve, Bosch part # 265772, or repairclinic.com # 467537.
The Hot water valve if need be is Bosch part # 171295 or repairclinic.com # 423900 )

 Control module has failed. ( Not very likely either...but possible...if not the valves. )

Let me know what you find as I will watch for your reply here. Thanks for visiting "fixya". Please take a moment and rate the info provided for you here today.

Let me know if you require further assistance.

Thanks and good luck.

macmarkus :)


More: